It is currently 18 Oct 2018 23:13

All times are UTC + 1 hour




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: FAT32 Problem
PostPosted: 11 Apr 2018 10:44 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Good morning,
I'm using ARM STM32F407VGT6 to drive a 5 "LCD with the FT800 driver. I use the FAT32 library to upload images to a micro-sd.
Up to now I have always used 4GB micro-sd in class 10, everything has always worked perfectly. Lately I bought some 8GB micro-sd in class 4 with the result that the images are not loaded / displayed correctly.
I tried to vary the SPI speed from SPI_FPCLK_DIV8 to SPI_FPCLK_DIV16, but I did not get any results.
I tried to load different versions of the FAT32 library, 108_fat32_library_V3.2.0.0 and 108_fat32_library_V3.1.0.1 but without improvements. Do you have any suggestions to give?


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 12 Apr 2018 09:20 
Offline

Joined: 07 Jun 2016 12:16
Posts: 135
Hi
Look here viewtopic.php?f=178&t=71746
we are waiting for the release of the repaired version.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 13 Apr 2018 10:39 
Offline
mikroElektronika team
User avatar

Joined: 25 Jan 2008 09:56
Posts: 10015
Hi,

Please try the library on the link above and see if it solves your issue.

Regards,
Filip.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 16 Apr 2018 14:53 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Good morning,
I created the pachage file with the file __Lib_FAT32_STM32_M3_M4_M7.emcl. I recompiled my program and loaded it on the processor. Unfortunately the problem is still present and presents itself without any difference compared to the version compiled with the FAT32 library previously loaded.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 23 Apr 2018 09:17 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Good morning, no news about it?
For our company this is a big problem, as we have purchased a number of micro-sd cards and we have some board in production that need to be delivered, it would be important that the resolution of the problem was approached with the utmost seriousness and timeliness.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 24 Apr 2018 09:34 
Offline
mikroElektronika team
User avatar

Joined: 25 Jan 2008 09:56
Posts: 10015
Hi,

Please, can you tell me which variety of SD cards are you using ?
Did you try changing the allocation unit size when formatting the cards ?
Do the labels display correctly on the screen ?

Regards,
Filip.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 27 Apr 2018 11:32 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Hi Filip,
Please, can you tell me which variety of SD cards are you using ?
Kingston 8GB HC class 4 (not work)
Transcend 4GB HC class 10 (work perfectly)

Did you try changing the allocation unit size when formatting the cards ?
I try a lot of test, i've changed the cluster size (512B, 1k, 2k, 4k, 8k, 16k, 32k, 64k)

Do the labels display correctly on the screen ?
on my TFT panel, all label, text, line, circle, are displayed correctly, only bitmap are corrupted and not displayed

regards
Tredielettronica


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 30 Apr 2018 09:13 
Offline
mikroElektronika team
User avatar

Joined: 25 Jan 2008 09:56
Posts: 10015
Hi,

Please, can you attach the minimal project that represents this issue, just image displaying ?

Regards,
Filip.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 02 May 2018 08:46 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Hi Filip
here you are the minimal project and the image

thanks
best regards
TrediElettronica


Attachments:
MyProg.rar [2.72 MiB]
Downloaded 46 times
Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 04 May 2018 14:25 
Offline
mikroElektronika team
User avatar

Joined: 25 Jan 2008 09:56
Posts: 10015
Hi,

Judging from your HSI clock configuration, I doubt that the MCU will work correctly, the division and multiplication factor are not correct for the 168MHz.

Could you please use the STM32F407VG_PLL_Int_Osc_16MHz_to_140MHz.cfgsch scheme from the compiler and see if this will help ?

Also, could you try changing the SPI clock and mode ?

Regards,
Filip.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 01 Jun 2018 09:58 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Good morning,
I had to suspend the solution of the problem temporarily having had to deliver several machines.
I had to buy other micro-sd, since I could not use them on the card in any way.
But now I have to resume the speech, as I find myself a number of miscr-sd purchased and not usable.
I made several tests including that of using the configuration file you told me, I tried to change the clock and the SPI mode, but no change. The micro-sd card does not work.
But I verified something very strange.
I will indicate with MSD-1 the micro-sd card not working and MSD-2 the micro-sd (same brand Kingston, same class 4, but different manufacturer CHINA instead of TAIWAN). The MSD-2 works !!! Can you hypothesize the motivation?

It also happens, (problem not inherent the micro-sd) that using the configuration file that I have indicated, that the UART (which I use to communicate / receive with another card) has a strange behavior, some data received are corrupted, the problem is solved by multiplying the baudrate by a factor of 1.2 upon initialization. Can you give me directions?

Thank you
regards


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 01 Jun 2018 11:03 
Offline

Joined: 07 Jun 2016 12:16
Posts: 135
Mikroe released a new version
(Maybe all bugs are fixed ? )
https://libstock.mikroe.com/projects/vi ... 32-library

Try it.


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 04 Jun 2018 08:09 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
No, unfortunately, even with the new version, the problem persists


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 15 Jun 2018 08:37 
Offline

Joined: 06 Sep 2016 08:33
Posts: 15
Hi Filip,
no news about my last post (June 1, 2018)


Top
 Profile  
 
 Post subject: Re: FAT32 Problem
PostPosted: 18 Jun 2018 11:05 
Offline
mikroElektronika team
User avatar

Joined: 25 Jan 2008 09:56
Posts: 10015
Hi,

I have tried various 8GB SD cards, SanDisk, Kingston, Transcend (all class 4) and I always got your code working.

Regards,
Filip.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: