It is currently 25 Feb 2018 07:06

All times are UTC + 1 hour




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: 09 Feb 2018 07:21 
Offline

Joined: 08 Feb 2018 01:05
Posts: 2
Hello folks,

I have written simple below program to test UART in PIC16F18877. I am using 20MHz crystal frequency.
I have used MPlab IPE to write program to PIC.


void main()
{
UART1_INIT(9600);
Delay_ms(100);
UART1_Write_Text("\r\nHelloWorld");
Delay_ms(1000);
}

I am able to see HelloWorld as output.
But it is executing infinite times.
I have not used any loops here.

Can someone please suggest me how to solve it ?

Thanks in advance.


Top
 Profile  
 
PostPosted: 09 Feb 2018 10:43 
Offline

Joined: 27 Jun 2010 12:07
Posts: 878
Location: England
I see that you already have a solution on the Microchip site.


Top
 Profile  
 
PostPosted: 09 Feb 2018 18:05 
Offline
mikroElektronika team
User avatar

Joined: 15 Jan 2016 12:50
Posts: 1715
Hi,

Welcome to the MikroE forum.

You can check in Project -> Edit Project if Watchdog Timer
is Enabled, if it is, you can try to disable it.

Kind regards,
Lana


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: