MikroElektronika Forum
https://forum.mikroe.com/

Windows 10 update killed my MikroProg for PIC
https://forum.mikroe.com/viewtopic.php?f=192&t=71509
Page 1 of 1

Author:  kpayea [ 11 Jan 2018 05:42 ]
Post subject:  Windows 10 update killed my MikroProg for PIC

Once again, Microsoft forced an update on me which has killed access to my MikroProg for PIC. Because the drivers are not signed, Windows 10 update thinks they are hostile and either removes or disables the driver. You need to fix this.
I have searched all over the forum and the site and I can't find any help for this. I have uninstalled MikroProg Suite and deleted the driver as suggested. I then restarted the machine with the Driver Signature Enforcement off and re-installed MikroProg Suite 2.60. Still doesn't work.

If there is a more recent driver for the programmer, I can't find it anywhere on your site. I got the latest from the MikroProg page for this whole process.

I'm really not looking forward to doing this again every year when Microsoft forces an "upgrade" to Windows 10.

Did I say it before? You need to fix this. Telling every user to go through hours or dorking around with Windows every year is very unprofessional.

Keith

Author:  lana.arsic [ 11 Jan 2018 18:44 ]
Post subject:  Re: Windows 10 update killed my MikroProg for PIC

Hi Keith,

I'm sorry for the inconvenience.

Did you try this suggestion?

viewtopic.php?f=192&t=69817&view=next#p280247

We have tried on many computers with the newest version of Windows 10
and it was working properly, it was only needed to install drivers and mikroProg Suite explicitly as administrator.

Drivers from mikroProg for PIC, dsPIC and PIC32 are the newest ones.

Kind regards,
Lana

Author:  kpayea [ 11 Jan 2018 21:33 ]
Post subject:  Re: Windows 10 update killed my MikroProg for PIC

I just went through that entire sequence and it still doesn't work. I attached a screen grab. This was after a restart, and the results are the same with or without a hub.

I guess it is possible that the MikroProg has suffered a hard failure, coincident with the Win10 Update.

Is it possible to use a PICKit 3 or other device instead of the MikroProg for debugging? I know I can use it to burn a hex file, but I need to use a debugger.

I know that Microsoft owns part of the driver problem, but Windows 10 is here to stay and you need to get the driver signed so that it can be installed without these issues.

Please let me know if you have any other ideas.

Thanks,

Attachments:
File comment: screen grab from Device Manager
DriverFail.JPG
DriverFail.JPG [ 86.97 KiB | Viewed 229 times ]

Author:  lana.arsic [ 12 Jan 2018 18:07 ]
Post subject:  Re: Windows 10 update killed my MikroProg for PIC

Hi Keith,

I apologize once again for the inconvenience.

Can you please try to install drivers manually from Device manager, by choosing option:
Browse my computer for driver software and navigate to the .exe file which you have downloaded?

https://win10faq.com/install-or-update- ... dows-10-2/

If that doesn't help, can you please submit a ticket, since we really
cannot reproduce the same behavior?

Regarding PICkit3, unfortunately, it is not possible to debug code from our compiler, only to program it by loading .hex file.

Kind regards,
Lana

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/