It is currently 20 Jan 2019 20:06

All times are UTC + 1 hour




Post new topic Reply to topic  [ 72 posts ]  Go to page Previous  1, 2, 3, 4, 5
Author Message
PostPosted: 14 Sep 2016 19:06 
Offline

Joined: 05 Oct 2015 12:38
Posts: 57
Aleksandar.Mitrovic wrote:
Which language pack do you have?
Have you tried to install drivers on some PC without language pack?

Please take a look at my screenshots. I have changed language of my OS to english so I can show you errors.
The language of the OS is not the source of the driver problems.


Top
 Profile  
 
PostPosted: 20 Sep 2016 14:36 
Offline
mikroElektronika team
User avatar

Joined: 11 Mar 2015 12:48
Posts: 1697
Hi,

Can you please try it with this drivers please.
First uninstall the old one and guide the installation to that folder.

Kind regards,
Aleksandar


Attachments:
VCP_drivers.rar [9.67 KiB]
Downloaded 203 times
Top
 Profile  
 
PostPosted: 20 Sep 2016 20:06 
Offline

Joined: 05 Oct 2015 12:38
Posts: 57
Aleksandar.Mitrovic wrote:
First uninstall the old one and guide the installation to that folder.

I can't uninstall "the old one" because "the old one" simply failed to install in the first place. So that's logical.

Aleksandar.Mitrovic wrote:
Can you please try it with this drivers please.


This one has been installed successfully but it's giving me ERROR 10 all the time. So something is still wrong. Please look at the screenshots.

PS: I have also tested the driver given by you on VMWARE / Windows XP and it works OK.


Attachments:
installing_errr.png
installing_errr.png [ 17.65 KiB | Viewed 6456 times ]
devgr.png
devgr.png [ 18.2 KiB | Viewed 6456 times ]
installinggg.png
installinggg.png [ 58.76 KiB | Viewed 6456 times ]
Top
 Profile  
 
PostPosted: 21 Sep 2016 16:00 
Offline
mikroElektronika team
User avatar

Joined: 11 Mar 2015 12:48
Posts: 1697
Hi,

We didnt have any problems with installing this drivers on Windows 10 or Windows 8.1 PC.
When you start installation of the drivers and guide installation to the folder do you have option to chose between drivers?

Best regards,
Aleksandar


Top
 Profile  
 
PostPosted: 21 Sep 2016 21:42 
Offline

Joined: 05 Oct 2015 12:38
Posts: 57
No, I don't have such option.
Anyway, please take a look, I've made a video of entire uninstall / install again your driver (from attacchment) process.
Attachment:
bandicam 2016-09-21 22-21-38-953.zip [2.65 MiB]
Downloaded 183 times

You can see that I point at location E:\VCP_drivers, etc,
You can also see error messages.
Everything in English.
If you need any more information or testing just tell me... and I really need your drivers working on that machine, using VMWare with Windows XP is tedious.


Top
 Profile  
 
PostPosted: 22 Sep 2016 15:36 
Offline
mikroElektronika team
User avatar

Joined: 11 Mar 2015 12:48
Posts: 1697
Hi,

In the video I saw that you have:
Attachment:
VCP_driver_install.jpg
VCP_driver_install.jpg [ 65.97 KiB | Viewed 6436 times ]


Have you tried to check the list of the offered drivers?

Kind regards,
Aleksandar


Top
 Profile  
 
PostPosted: 22 Sep 2016 18:21 
Offline

Joined: 05 Oct 2015 12:38
Posts: 57
I have tried now, there are several drivers but I don't think they are compatible.
Buuut I think your driver should work just after installing it.
Anyway, you can take a look at the video which drivers I have.
Attachment:
list_of_drivers.zip [817.72 KiB]
Downloaded 205 times

Also... there are chipkit and microchip MCP drivers there, but no driver for Mikroelektronika CDC.


Top
 Profile  
 
PostPosted: 23 Feb 2018 20:57 
Offline

Joined: 23 Feb 2018 20:52
Posts: 1
Hi

was this issue resolved, I'm also getting error 10 in window 8.1 64bit only. XP is ok.
Using new drivers from the attachment from this post

Thanks


Top
 Profile  
 
PostPosted: 15 Oct 2018 05:34 
Offline

Joined: 05 Apr 2015 23:00
Posts: 7
Apologies for waking up/hijacking an old topic. I have a PIC Clicker app using this library, which works fine communicating with a Windows (10) host. A friend is trying to use it connected to a Mac running OS-X 10.9.5. It seems to show up on the Mac as a /dev/tty.usbmodemNNNN device, but trying to open it from an application just hangs.

Has anyone tried this library with a Mac host? Is there a special driver needed?

Thanks.


Top
 Profile  
 
PostPosted: 16 Oct 2018 08:12 
Offline
mikroElektronika team
User avatar

Joined: 25 Jan 2008 09:56
Posts: 10150
Hi,

We didn't test the library on the Mac at the time of its creation, so I don't have any information regarding this.

Regards,
Filip.


Top
 Profile  
 
PostPosted: 01 Nov 2018 19:31 
Offline

Joined: 05 Apr 2015 23:00
Posts: 7
I'm trying it on a Linux system now... it creates a /dev/ttyACM0 port okay, and I can write to the port ok (and see that the PIC board receives ok based on blinky light activity), but can't read anything back. Does that suggest anything to try?


Top
 Profile  
 
PostPosted: 19 Nov 2018 01:16 
Offline

Joined: 05 Apr 2015 23:00
Posts: 7
Followup in case anyone is interested:

#1 In the VCP_Descriptor setup in the PIC code, be sure to keep wMaxPacketSize as 64 (0x40) for Bulk In and Out endpoints, even if your application doesn' t need that much. Linux and OSX will not work right otherwise, at least with default drivers. Changing that allowed my device to work with Linux, and with OSX using most software.

#2 My host application is written in Tcl/Tk, and on the Mac (only) that still doesn't work with the CDC device. I think that's because the device shows CTS handshake as inactive, and even if I tell Tcl to ignore handshake, it won't transmit (it does receive though). Seems like a combination of limitations in the basic OSX CDC driver and issues with Tcl serial handling on OSX. I have a workaround using a small Python interface between the Tcl code and the serial device.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 72 posts ]  Go to page Previous  1, 2, 3, 4, 5

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: